How To Fix “1m sub-circuit board is not installed” Error on VBA and MyBoy

31

Game emulators are such amazing and brilliant applications created by generous programmers. This application allows users to play almost any games on a computer or mobile device without using the actual game console.

However, upon using your favorite emulator, sometimes, you may experience a strange and annoying problem. One common problem is the Internal Battery Run Dry Error for Visual Boy Advance GBA emulator.

Featured Videos


The second most popular error is the “1m sub-circuit board is not installed”. Do not fret; many of you including me, experienced the same problem, and that’s what we are going to address in this article.

Hopefully this will fix your problem if you’re experiencing it right now.

Fixing the 1m sub-circuit board is not installed on emulator

Steps on how to fix 1m sub-circuit board is not installed error

Fixing “1m sub-circuit board is not installed” error is incredibly easy and straightforward, although not all, many emulators have the feature to fix this issue. The fix is merely changing the save type from Flash 64kb to Flash 128kb.

Fix 1m sub-circuit board change save type 128k
Fix 1m sub-circuit board error myboy flash 128k

In VisualBoy Advance
Go to Options -> Emulator -> Save Type -> and finally, select Flash 128K.

For MyBoy (Popular GBA emulator for Android)
Go to More -> Settings -> Advanced -> Cartidge save type -> Select Flash 128K.

Why & How Does This Error Happen?

In most cases, this error occurs when you have 64kb save types instead of 128. Some emulators have a severe problem when saving a game; instead of 128kb it automatically saves to 64kb. If this happens to you, use the alternative fix below.

Alternative Fix

For Visual Boy Advance users, if the error persists after following the mentioned steps above, give this alternative solution a try.

Zorlon, the forum administrator of emuparadise created a version of vba-over.ini that will fix the issue. What the file does is, it auto-setup the games that do not auto-detect correctly.

Vba-over ini file to fix 1m sub-circuit board error

Download the file, extract, copy vba-over.ini, and paste it in the same folder location where your VisualBoy Advance is.

To Sum This Up

1m sub-circuit board is not installed is a common error that usually occurs when using Visual Boy Advance emulator or even to other popular GBA emulators you know.

Luckily, there’s a quick fix for this problem, and that’s by simply changing the save type to 128K; that’s it.

Did the fix mentioned above solve your problem? I would like to hear about your experience regarding this error and the steps you took to fix it.

Subscribe
Notify of

This site uses Akismet to reduce spam. Learn how your comment data is processed.

31 Comments
Inline Feedbacks
View all comments

Its not working in gba

Still won’t let me save my game on Pokémon Gaia it continues to say save error and I’d like to be able to play after I beat the Pokémon league

or better yet where is the options in Vba because i cant find it in there

where do we change the save file from 64 to 128 ?

thank you

For vba, make sure you have all of the directories are set as the same file your emulator is inside of.
Go to Options > Emulator >Directories…

and how i know it?

delete the previous save file and then start new one you will see the error is gone

oh i got the answer

For reGBA emulator (often found on portable emulator devices like the PocketGO and RG350) you open the emulators menu, go to Display Settings, then change the “Boot from” setting from “Cartridge ROM” to “GBA BIOS”.

It Worked, thank you so much

It didn’t work for me I’m using visual boy advance and it’s still showing that 1m sub- circuit board is not installed

Yep same to me

It not worked pls help me

make sure you delete any other save files if you made some previously.

I did both of the possible solutions, but anyone could help me, the leyend of 1m sub-circuit board is not installed, keep on in my emulator

try my boy pc downloud

thank you

It worked. The van. Over. Ini worked. Thanks a lot

Strangely, I have a Fire Red rom runs perfectly fine, but when I copy and save it somewhere else, the copy face 1M circuit board issue while the original still ok with Flash 64K.

Yeah, me too, it just appears to a hack rom I have…

I change the save type but,i couldn’t able to play now

What if I’m playing on GBA4iOS